Upgrade warnings

Revision as of 11:14, 31 October 2011 by Helen Foster (talk | contribs) (removing title, category)

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.5. Up-to-date documentation for the latest stable version of Moodle may be available here: Upgrade warnings.

If you reached this page from a warning during an upgrade from a stable version then it's probable that some of our branch changes have affected you.

From November 2010 until March 2011 we were using the "master" in git (HEAD in CVS) to work on the stable version of Moodle 2.0.x. In March 2011 we split the stable development to a separate branch called MOODLE_20_STABLE (see diagram below).

If you intend to stay with the most recent stable version of Moodle, then you need to switch your checkout over to use the MOODLE_20_STABLE branch. If you are using CVS, then use

   cvs -q update -dPr MOODLE_20_STABLE

If you are using Git, then you must create new local branch in your clone that will track the remote stable branch and switch to it.

   git branch --track local_20_STABLE origin/MOODLE_20_STABLE      (1)
   git checkout local_20_STABLE                                    (2)
   git pull                                                        (3)

Note that you can choose any name for the local branch. In the example above, the local branch is called local_20_STABLE. At the line (1) the new local branch is created and set to track the remote branch MOODLE_20_STABLE. At the line (2) we switch to the newly created branch. At the line (3) the git-pull command fetches recent changes from the upstream and merges them into your local branch. To update your Moodle next week, you can run just the line (3).

For more about how Moodle versions are managed in git and CVS, see our dev:Moodle_versions page.