Difference between revisions of "PHP"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.2. Up-to-date documentation for the latest stable version is available here: PHP.

(Change HTML line to 'in moodle)
(Minimum version requirements: add other PHP pages)
Line 11: Line 11:
  
 
The minimum version of PHP required for Moodle is listed in the [[Installing_Moodle#Requirements|requirements section of the installation instructions]]
 
The minimum version of PHP required for Moodle is listed in the [[Installing_Moodle#Requirements|requirements section of the installation instructions]]
+
 
 +
==Other PHP pages==
 +
[[Installing Oracle for PHP]]
 +
[[PHP error logs]]
  
 
== See also ==
 
== See also ==

Revision as of 18:16, 13 February 2009

PHP is the scripting language in which Moodle is developed. PHP does not stand alone, it is tightly integrated with a suitable HTTP Server. Most people use the Apache HTTP Server for this purpose although a number of others are supported.

PHP describes itself as "a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML."


Installation

Usually PHP is installed alongside Apache and MySQL in a combination known as AMP, see Installing AMP for details.

Minimum version requirements

The minimum version of PHP required for Moodle is listed in the requirements section of the installation instructions

Other PHP pages

Installing Oracle for PHP PHP error logs

See also