Environment

Revision as of 12:18, 13 February 2009 by Rhodry Korb (talk | contribs)

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.0. Up-to-date documentation for the latest stable version is available here: Environment.

Location: Administration > Server > Environment


The environment page enables you to check that your site meets all system requirements for your current and future versions of Moodle. It is important to check system requirements prior to upgrading.


Moodle version 1.5.3

  • MySQL version - 3.23 or later is required
  • PHP version - 4.1.0 or later is required
  • The php_extension mbstring is recommended to be installed/enabled

Moodle version 1.6

  • MySQL version 4.1.12 or later for sites that are exclusively Latin-1, 4.1.16 if you have other languages, or PostgreSQL 7.4.x or later
  • PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
  • The php_extension iconv is recommended to be installed/enabled
  • The php_extension mbstring is recommended to be installed/enabled

Moodle version 1.8

Moodle version 1.9

Requirements

  • PHP version 4.3.0 or later is required
  • Database (pick one):
    • MySQL 4.1.16 or
    • Postgres 8.0 or
    • MSSQL 9.0 or
    • Oracle 9.0

See also

Moodle version 2.0

Requirements

  • PHP: 5.2.8 or later is required
  • Database (pick one):
    • MySQL 4.1.16 or
    • Postgres 8.0 or
    • MSSQL 9.0 or
    • Oracle 9.0
    • SQLite 3 (experimental)

See also