Difference between revisions of "Environment"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.0. Up-to-date documentation for the latest stable version is available here: Environment.

m (Still needs upgrade)
(Moodle version 1.8 requirements)
Line 5: Line 5:
 
The environment page enables you to check that your site meets all system requirements for your current and future versions of Moodle. It is important to check system requirements prior to [[Upgrading|upgrading]].
 
The environment page enables you to check that your site meets all system requirements for your current and future versions of Moodle. It is important to check system requirements prior to [[Upgrading|upgrading]].
  
==1.5.3==
+
 
 +
==Moodle version 1.5.3==
  
 
*MySQL version - 3.23 or later is required
 
*MySQL version - 3.23 or later is required
Line 11: Line 12:
 
*The php_extension mbstring is recommended to be installed/enabled
 
*The php_extension mbstring is recommended to be installed/enabled
  
==1.6==
+
==Moodle version 1.6==
  
*MySQL version 4.1.12 or later for sites that are exclusively [http://czyborra.com/charsets/iso8859.html Latin-1], 4.1.16 if you have other languages, or PostgreSQL 7.4.x or later.
+
*MySQL version 4.1.12 or later for sites that are exclusively [http://czyborra.com/charsets/iso8859.html Latin-1], 4.1.16 if you have other languages, or PostgreSQL 7.4.x or later
 
*PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
 
*PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
 
*The php_extension iconv is recommended to be installed/enabled
 
*The php_extension iconv is recommended to be installed/enabled
 
*The php_extension mbstring is recommended to be installed/enabled
 
*The php_extension mbstring is recommended to be installed/enabled
  
==1.8==
+
==Moodle version 1.8==
 +
 
 +
*MySQL version 4.1.16 or later is required, or PostgreSQL 7.4.x or later
 +
*PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
 +
*[[admin/environment/unicode|Unicode]] is required
 +
*The [[admin/environment/php extension/curl|php_extension curl]] is recommended to be installed/enabled
 +
*The [[admin/environment/php extension/iconv|php_extension iconv]] is recommended to be installed/enabled
 +
*The php_extension mbstring is recommended to be installed/enabled
 +
*The [[admin/environment/php extension/openssl|php_extension openssl]] is recommended to be installed/enabled
 +
*The php_extension tokenizer is recommended to be installed/enabled
  
==1.9==
+
==Moodle version 1.9==
  
==2.0==
+
==Moodle version 2.0==
 
*PHP version 5.2.0 or later is required
 
*PHP version 5.2.0 or later is required
  

Revision as of 08:29, 28 August 2007

This page requires updating for Moodle 2.0. Please do so and remove this template when finished.


Location: Administration > Server > Environment


The environment page enables you to check that your site meets all system requirements for your current and future versions of Moodle. It is important to check system requirements prior to upgrading.


Moodle version 1.5.3

  • MySQL version - 3.23 or later is required
  • PHP version - 4.1.0 or later is required
  • The php_extension mbstring is recommended to be installed/enabled

Moodle version 1.6

  • MySQL version 4.1.12 or later for sites that are exclusively Latin-1, 4.1.16 if you have other languages, or PostgreSQL 7.4.x or later
  • PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
  • The php_extension iconv is recommended to be installed/enabled
  • The php_extension mbstring is recommended to be installed/enabled

Moodle version 1.8

  • MySQL version 4.1.16 or later is required, or PostgreSQL 7.4.x or later
  • PHP version 4.3.0 or later is required (but don't use versions 5.0.0 to 5.0.6 which were buggy)
  • Unicode is required
  • The php_extension curl is recommended to be installed/enabled
  • The php_extension iconv is recommended to be installed/enabled
  • The php_extension mbstring is recommended to be installed/enabled
  • The php_extension openssl is recommended to be installed/enabled
  • The php_extension tokenizer is recommended to be installed/enabled

Moodle version 1.9

Moodle version 2.0

  • PHP version 5.2.0 or later is required