Talk:Non-standard blocks

Revision as of 20:33, 26 April 2006 by Dan Marsden (talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 1.9. Up-to-date documentation for the latest stable version is available here: Non-standard blocks.

Need a definition of non-standard blocks !!

Do they means that they won't run on standard moodle installs ? Do they means that they will cause incompatability problems on standard moodle ? Do they mean that they won't integrate with upgrades ?

I don't touch them because of the above presumptions. Stephen Digby 06:56, 23 April 2006 (WST)

good point! --David Scotson 21:49, 23 April 2006 (WST)

my definition of a non-standard block would be a block that does not come as "standard" when you download the Moodle package - Non-standard blocks must be installed seperately from the initial install. each of these come with an amount of risk. let's use the Choice block as an example: - it only runs on Moodle 1.6 or higher - installation on anything below 1.6 could cause problems with your site. If I had released my earlier versions of the choice block before testing locally, you could have had all sorts of incompatibility problems with your site. There aren't many people using the choice block (there aren't many people running 1.6 in production yet) - so the block may have had some testing by the developer, but you don't know how well that has been done. - The choice block won't "integrate with upgrades" as when you upgrade your moodle installation, you aren't going to get any updated code for the choice block. - you will have to download the new version of the choice block manually. - there might not be an upgrade available at the same time as a new release to Moodle - (the block/code developer may have left the building, be "too busy" etc etc, I'd like to say this wouldn't happen with the choice block :-) )- these are all risks you will need to weigh up in your decision to install a custom block or module. because of these risks, if you become reliant on a non-standard block or module then it may delay your ability to upgrade when new versions of moodle are available untill someone upgrades the custom block/module you are reliant on. - however, most of the time Moodle trys to maintain backward compatibility, so you may find that new versions of moodle work fine with the custom block/module...... --Dan Marsden 04:33, 27 April 2006 (WST)