PowerPoint importieren

Wechseln zu: Navigation, Suche

Hinweis: Sie sind auf den Seiten der Moodle 1.9 Dokumentation. Die Dokumentation der aktuellsten Moodle-Version finden Sie hier: PowerPoint importieren.


Mit dieser Funktionalität ist es möglich, Texte und Grafiken aus einer MS PowerPoint-Präsentation zu extrahieren und als Lektionsseiten in eine Lektion zu importieren. Die Seitentitel entsprechen danach den der PowerPoint-Präsentation. Die Sprungverweise werden leer belassen, so dass die Navigation innerhalb der Lektion entsprechend den Lektionseinstellungen zur Ablaufkontrolle erfolgt.

Einfache Texte und Grafiken werden sich weitgehend problemlos importieren lassen, ebenso wie einfache Aufzählungen. Hingegen können Textformatierungen wie Unterstreichungen nicht problemlos importiert werde.

Diese Funktionalität richtet sich in erster Linie an Trainer, die ihr grobes Lektionskonzept lieber in PowerPoint entwickeln. Erwarten Sie bitte nicht, dass die erweiterten grafischen und navigatorischen Eigenschaften von PowerPoint übernommen werden, siehe auch die Tipps weiter unten. Ältere Moodle-Versionen (vor 1.8) bedürfen u.U. leichter Code-Anpassungen, wenn Powerpoint 2003 zum Einsatz kommen soll.

Beachten Sie jedoch, dass die eine Präsentation von geringer inhaltlicher Qualität nicht dadurch besser wird, dass man sie in Moodle importiert - was im übrigen für jeglichen Inhalt gilt. Insbesonders betrifft das auch die Layoutqualität Ihrer Präsentation - schlecht lesbare Schriften und exzessiver Gebrauch von Aufzählungszeichen erleichtern Ihren Teilnehmer das Leben nicht unbedingt, egal ob es sich um eine Moodle-Lektion oder eine PowerPoint-Präsentation handelt!


Anleitungen

Aus PowerPoint 2003 Webseiten erstellen und in Moodle 1.9 importieren

  1. Das Webverzeichnis erstellen.
    • Öffnen Sie Ihre Präsentation in PowerPoint.
    • Klicken Sie auf Datei > Speichern unter....
    • Passen Sie die Speichereinstellungen an.
    • Setzen Sie die Einstellung des Dateityps auf Webseite.
    • Klicken Sie auf Speichern und verlassen Sie Powerpoint.
  2. Verwenden Sie den Windows-Explorer oder ein anderes geeignetes Programm, um
    • das neu erstellte Webverzeichnis als ZIP-Datei zu speichern.

Aus PowerPoint 2000 Webseiten erstellen und in ältere Moodle-Versionen (vor 1.9) importieren

  1. Das Webverzeichnis erstellen.
    • Öffnen Sie Ihre Präsentation in PowerPoint.
    • Klicken Sie auf Datei > Speichern unter....
    • Passen Sie die Speichereinstellungen an.
    • Setzen Sie die Einstellung des Dateityps auf Webseite.
    • Klicken Sie auf Speichern und verlassen Sie PowerPoint.
  2. Verwenden Sie den Windows-Explorer oder ein anderes geeignetes Programm, um
    • das neu erstellte Webverzeichnis als ZIP-Datei zu speichern.
    • Stellen Sie dabei sicher, dass sich alle Ihre erstellten HTML-Dateien in diesem Ordner befinden.

Anweisungen für Moodle

Der Import der Powerpoint-Datei (genauer: des erstellten Webverzeichnisses) erfolgt so:

  1. Legen Sie eine Lektion mit den von Ihnen gewünschten Einstellungen an.
  2. Wählen Sie im Auswahl-Menü der ersten Seite Powerpoint importieren.
  3. Wählen Sie im folgenden Dialog die erstellte ZIP-Datei aus.
  4. Klicken Sie auf Fortfahren.
  5. Bei Bedarf können Sie die importierten Lektionsseiten weiter anpassen und bearbeiten.

Tipps

  1. Halten Sie Ihre PowerPoint-Präsentation einfach, nur Text ist am besten.
    • Verwenden Sie keine Seitenzahlen.
    • Verwenden Sie keine Textkästen mit Grafiken oder Hintergründen.
    • Masterfolien werden nicht importiert, ggf. entfallen damit auch die Fußzeilen!
    • Wasserzeichen oder Text über Grafiken bereiten sicher Probleme.
    • Es werden nur manche Aufzählungszeichen ("Bullets") importiert.
    • Verwenden Sie keine Sonderzeichen.I
  2. Grafiken können theoretisch als Teil der Präsentation importiert werden, aber
    • sie müssen u.U. direkt in die Lektion eingefügt werden.
    • Der Import von mehreren Grafiken pro Seite funktioniert selten.
  3. Überprüfen Sie jede Seite aus Teilnehmerperspektive:
    • Sind alle Aufzählungszeichen vorhanden?
    • Überprüfen Sie die Texte zweimal (!), besonders wenn viel Text auf einer Seite ist.
    • Sind die Grafiken korrekt importiert worden?
  4. Fehlen Daten?
    • PowerPoint 2003 Import funktioniert nicht oder sehr mangelhaft in älteren Moodle-Versionen (vor 1.8).
    • Nicht-englische Präsentationen scheitern manchmal am Zeichensatz.
    • Überprüfen Sie auch Ihre PowerPoint-Version.
  5. Sie wollen ein MS Word-Dokument in Moodle als Lektion importieren?
    • Lesen Sie die Microsoft Anleitung über den Export von Folien aus Word-Dokumenten (siehe MS Word-Hilfe).
    • Verwenden Sie Gliederungen mit maximal zwei Ebenen in MS Word.
    • Die erste Ebene sollte der Titel, die zweite der Inhalt sein.
    • MS Word-Dokument speichern, dann Gliederung nach PowerPoint exportieren.
    • Dann den weiteren Instruktionen von oben folgen.

Beispiele

  1. Verwenden Sie PowerPoint als Storyboard mit einfachen Texten (d.h. ohne spezielle Formatierungen) und fügen Sie Beschreibungen für die Sprungverweise hinzu. Bedenken Sie, dass der erste Gliederungspunkt nach dem Import als Seitentitel erscheint. Die Beschreibungen für die Sprungverweise dienen Ihnen nur als Gedächtnisstütze, diese können Sie dann aber per Copy&Paste in die Beschreibungsfelder der Sprungverweise einfügen. Dies müssen Sie leider für jeden einzelnen Sprungverweis durchführen und diese Gedächtnisstützen dann aus dem Inhaltsfeld löschen.
  2. Sie sollten PowerPoint-Dateien verwenden, die dafür konzipiert sind, allein von CD zu funktionieren, d.h. alle wesentlichen Dateien der Präsentation müssen direkt verfügbar sind. Manchmal ist es sogar sinnvoller, eine neue PowerPoint-Datei zu erstellen, anstatt eine bestehende nachzubearbeiten.
  3. Dieser englische Forumsbeitrag stellt eine ZIP-Datei ImportPPT_Stuff bereit, die eine einfache dreiseitige PowerPoint-Präsentation enthält, sowie eine weitere ZIP-Datei, die die Webseiten enthält, die aus dieser Präsentation erstellt wurden. Die hierbei verwendete Version ist PowerPoint 2003 ServicePack 2. Nach dem Entpacken von Stuff, funktionierte der Import von ImportPPT_2003_test_1_files.zip auf demo.moodle.org (Moodle 1.9 vom Mai 2008).

PowerPoint 2003 mit Moodle 1.9

Diese Kombination sollte ohne größere Manipulationen funktionieren.

Moodle 1.6

Moodle1.6

Für den Import von PowerPoint 2003 nach Moodle 1.6 lesen Sie die englischsprachige Anleitung. Ein Upgrade auf eine aktuellere Moodle-Version ist nicht zuletzt aus Sicherheitsgründen dringend empfohlen.

Direkter Import einzelner Seiten

Man kann von Hand auch einzelne OpenOffice- und PowerPoint-Folien in eine Lektion einfügen. Dies mag sinnvoll sein, wenn nur wenige Folien in eine bestehende Lektion eingebunden und die Darstellungen der Folien quasi wie ein Screenshot verwendet werden sollen. Nutzer, die damit schon Erfahrungen machten, berichten, dass dieser Prozess abhängig von der Moodle-Version, der Anzahl der Seiten und der Bildaufbau-Geschwindigkeit 2-3 Minuten pro Lektionsseite betragen kann.

Der Trick dabei ist, dass Sie die betreffenden Lektionsseiten als Grafikdateien speichern. Diese Grafiken wiederum binden Sie unter Bentuzung des HTML-Editors in die Lektionsseite ein. Diesen Vorgang müssen Sie allerdings für jede Folie wiederholen, was letztlich sehr zeitintensiv sein kann. Eine detaillierte Anleitung finden Sie im englischen Artikel. Allerdings hängt die Vorgehensweise und die verwendeten Begrifflichkeiten von der Software bzw. der Software-Version ab. Konsultieren Sie daher auch die Hilfe-Seiten Ihrer Präsentationssoftware bzgl. dem Export von Folien als Grafik-Dateien.

Siehe auch

  • Import Powerpoint html to lesson - Diskussionsbeitrag im Kurs Using Moodle auf moodle.org
  • Lesson Forum thread - Diskussionsbeitrag im Kurs Using Moodle auf moodle.org
  • PowerPoint
  • Moodle-Tracker MDL-15755: Hier finden Sie eine einfache PowerPoint-Präsentation mit entsprechender ZIP-Datei. Das ZIP kann direkt importiert werden. Das ist nützlich bei der Fehlersuche und um auszuschließen, dass andere Teile Ihrer Moodle-Installation fehlerhaft sind. Sie können das ZIP z.B. nach demo.moodle.org importieren.
  • Moodle-Tracker MDL-5655: Hier finden Sie ein unvollständiges Patch zum Import von Webseiten, die mit OpenOffice Impress erstellt wurden.
  • Moodle-Tracker MDL-10513: Hier finden Sie ein Verfahren zum Import mehrerer Grafik-Dateien sowie ein Code-Patch zur Anzeige dieses Prozesses. Die Dateinamen bestimmen die Reihenfolge (img1 kommt vor img2).