Docs for other versions: 2.6 / 2.5 / 2.4 / 2.3 / 2.2 / 2.1 / 2.0 / 1.9

Upgrading to Moodle 1.8

From MoodleDocs
Jump to: navigation, search

Moodle1.8

This page lists issues specific to upgrading to Moodle 1.8. They should be read in conjunction with the generic upgrading instructions.


Contents

Before upgrading, please...

  • Check that your site meets all system requirements for 1.8 in Administration > Server > Environment
  • Check that any non-core modules and plugins are compatible with 1.8.
  • Do a full database backup!
  • Remember to purge PHP cache if using any PHP accelerator
  • Read Upgrading to Moodle 1.7 if you are upgrading to 1.8 from 1.6
  • Read Upgrading to Moodle 1.6 if you are upgrading from something earlier than 1.6

UTF-8 database encoding

For understanding upgrading to 1.8 and the UTF-8 encoding requirement, a small Moodle history lesson is required: Prior to 1.6, Moodle did not support UTF-8 across all languages and the encoding in which the data was stored in the database depended upon the language used in a particular course. From Moodle 1.6 onwards, all language packs are converted to UTF-8 and different languages may be used on the same page. Moodle 1.6 and 1.7 include a utility to migrate your database from any encoding to UTF-8.

From Moodle 1.8 onwards, the database migration utility is no longer included, as it is assumed that you upgrade from a UTF-8 encoded database.

Thus, if you wish to upgrade from 1.5 or an earlier version, you must first upgrade to 1.6 or 1.7, migrate your database to UTF-8, and then upgrade to 1.8. Similarly, if you are using Moodle 1.6 or 1.7 and have not yet migrated your database, you need to do so before upgrading to 1.8. Please refer to Upgrading to Moodle 1.6 for additional information.

Tip: It is possible to backup some 1.5 courses and then restore them to a 1.6 Moodle site. This will convert them to UTF-8. Then these courses can be backed up again and then restored to a 1.8 or higher Moodle site.

Roles and capabilities

In addition to many Roles fixes and refinements (see the list of Roles improvements in the Tracker), in Moodle 1.8 the system context is separated from the site context.

The site context in Moodle 1.8 is the "front page course" and its activities. Roles may be assigned in the site context via Administration > Front Page > Front Page roles.

After upgrading, it is recommended that you reset all legacy roles to default, since some of the default permissions have been changed. You can do that via Administration > Users > Permissions > Define Roles, click on each legacy role and review recommended permissions (dark background) or reset with Reset to defaults button.

In addition, in order to let your logged in users read the site news once logged in, please do as follows:

  1. As an administrator, navigate to Site Administration > Front Page > Front Page roles
  2. Click on the "Override roles" link
  3. Click on "Authenticated User"
  4. Find the Forum heading, then "View Discussions" (mod/forum:viewdiscussion capability) and tick the second radio input (Allow)
  5. At the bottom, press "Save changes"

Multi Authentication

If users are unable to login following an upgrade to 1.8 then most likely their account authentication method requires enabling.

Originally all existing accounts were enabled, now only accounts with enabled authentication plugins can log in. If you selected Manual accounts users created with email sign-up will be disabled now. Solution is go to Administration > Users > Authentication and enable Email-based self registration, but leave Self registration disabled under "common settings" lower on the page.

The No authentication (none) type should not be enabled on any production server. You can use phpmyadmin to convert all existing accounts created with 'none' to 'manual' or admin can change the auth type in Edit profile.

Themes

Due to major changes needed for accessibility and XHTML strict compliance most 3rd party themes must be updated to work correctly. Before reporting any error, please switch to Standard theme and try to replicate the problem.

Upgrading more than one version

In general, it is recommended to upgrade via each version of Moodle, for example 1.7 -> 1.8. An exception to this is when upgrading from 1.5 or 1.6, when it is recommended that 1.7 is skipped, in other words upgrade 1.5 -> 1.6 -> 1.8. (The main reason for this recommendation is that the default roles settings obtained when upgrading to 1.7 are not ideal for 1.8 onwards.)

See also